Common errors

Symptom

The following error message may be displayed when attempting to deploy NetSupport School to a PC:

Checking [TargetMachine] Client version... None detected

There was an error getting the platform information for [TargetMachine]. The network path was not found.

NetSupport School sent to 0 machines

Cause

This message will appear when the Windows Firewall or third-party firewall application is enabled with none of the required exceptions configured.

Solution

Ensure that the firewall is configured with the exception to permit access for file and print sharing as detailed in the Deploy scenarios in the previous section.

Symptom

When attempting to deploy NetSupport School to a target PC, a prompt for a user name and password appears for the connection to the target PC.

Regardless of the user name and password entered the connect to computer prompt will re-appear with the connect to network resource message.

Clicking Cancel displays:

Checking [TargetMachine] Client version... None detected

NetSupport School sent to 0 machines

Cause

The reason for the above behaviour is due to the configuration of the following local policy being set to Guest Only:

"Network Access: Sharing and Security model for local accounts"

Solution

In order to resolve the behaviour, the setting for the local policy needs to be changed from Guest Only to Classic - Local Users authenticate as themselves. Full details on how to apply this setting can be found in the Deploy scenarios section of this document.

Symptom

When attempting to deploy NetSupport School Student to a target PC, an error message appears on the Status tab:

Error installing NetSupport School [The directory name is invalid.]

Cause

The reason is that the NetSupport School\Deploy folder contains the NetSupport School.msi file.

Solution

In order to resolve the issue, you will need to replace the NetSupport School.msi file with the Setup.exe file in the NetSupport School\Deploy folder.

Symptom

When attempting to deploy NetSupport School to a target PC, the following error message may appear:

Checking [TargetMachine] Client version... None detected

Starting remote installation service...

Cause

The above error will appear when it is not possible to remotely start the installation service used during the deployment on the target PC. This could appear if the account details specified to connect to the target PCs do not have full Admin permissions.

Solution

In order to check this, confirm whether you can access the Services list for the target PC. This test is run on the machine you are deploying from:

  1. Right-click on My Computer\Computer and select Manage.

  2. Right-click on Computer Management and select Connect to another computer.

  3. Select the 'Another computer' tab and enter the target machine name you are attempting to deploy to and select OK.

  4. This will open the Computer Management pane on the target machine.

  5. Select the Services and Applications section and expand so the full list is displayed.

  6. Once the list is open, select Services and confirm that it is possible to view the services running on the target machine.

Note: If you are unable to access the Remote Services on the destination machine, it would indicate security permission settings are restricting the remote services from being started.

See also:

Deploy scenarios